Resolution
NetIQ Vulnerability Manager 5.0
fact
NetIQ Vulnerability Manager 5.5
fact
NetIQ Vulnerability Manager Agent for Windows 5.0
fact
NetIQ Vulnerability Manager Agent for Windows 5.5
symptom
ERROR: 'Failed to get endpoint's registration.'
symptom
ERROR: 'no such provider'
symptom
The user is unable to re-register a Windows Agent.
cause
The Windows Agent Windows.db file may be corrupted.
fix
To enable registration:
Ensure all NetIQ VigilEnt Windows agents in your system are of the same version.
If the NetIQ VigilEnt Agent service on the agent computer that is experiencing problems is running, stop it.
Locate the Windows.db file on a functioning agent computer and the Windows.db file on the agent computer that is experiencing problems.
Compare the name and file size of the two files.
If the files differ in name or size, copy the Windows.db file from the functioning agent computer to the agent computer that is experiencing problems.
Restart the NetIQ VigilEnt Agent service on the non-working machine.
Re-deploy the Windows Agent from the Console computer to the computer that is experiencing problems.
Re-register the agent.