General_MachineDown stops immediately, even though the Knowledge Script is set to run regularly (NETIQKB48138)

  • 7748138
  • 02-Feb-2007
  • 03-Sep-2010

Environment

NetIQ AppManager 6.0.2

Situation

General_MachineDown stops immediately, even though the Knowledge Script is set to run regularly.
After configuring the Knowledge Script to run at regular intervals, the job is dropped and starts, but then stops right away.

Resolution

An ICMP timeout that is too long could cause the Knowledge Script to not respond in a timely manner. The default value is 3 seconds, and a value of 32 seconds or less is recommended for the ICMP timeout property.

To change the value of ICMP timeout for running jobs:

  1. Double-click the running job. You can expand to a child job or select parent job if you want to select all child jobs for that parent. Select the Values tab.
  2. Enter a value less than 32 in Number of Seconds for ICMP timeout.
  3. Click OK to save the changes.
  4. Verify that the job restarted automatically. If you changed the Parent job properties, verify that all children jobs were restarted.
  5. If the job was not restarted, manually restart the job.

To change the default value of ICMP timeout for future jobs:

  1. In the Knowledge Script pane, double-click the Knowledge Script you want to modify.
  2. Select the Values tab.
  3. Enter a number is less than 32 in Number of Seconds for ICMP Timeout.
  4. Click OK to save the changes.

Cause

The value of the parameter Number of Seconds for ICMP timeout is higher than 32 seconds.

Additional Information

Formerly known as NETIQKB48138

The default timeout is two seconds.  In later versions of this script (AppManager 7.0 and higher), the default time out is 3 seconds, and the maximum time out is 120 seconds.