How can I determine what hotfixes or service packs have been applied to my agents or central compute (NETIQKB48084)

  • 7748084
  • 02-Feb-2007
  • 24-Jun-2010

Environment

Security Manager 5.X
Security Manager 6.X

Situation

How can I determine what hotfixes or service packs have been applied to my agents or central computers?

Resolution

To identify hotifixes or service packs installed, view the properties of the SMCommon.dll and EEMWF.dll files, which are located in the following folder depending on the Security Manager version you have installed or upgraded:

<installation path >\Program Files\MCS OnePoint\OnePoint (for Security Manager 5.0 installations and 5.1 upgraded central computers)

<installation path >\Program Files\NetIQ Security Manager\OnePoint (for Security Manager 5.1 and higher new installations and upgraded agents)

For 6.0, check the registry at HKEY_LOCAL_MACHINE\SOFTWARE\NetIQ\Security Manager\Configurations\Default\McsApplications\Operations Manager . Each component will be listed in the registry.

Where <installation path > is the location where you installed Security Manager.

Security Manager 6.5.2 version
SM 6.5.2.232 - Initial release with no hotfixes or service packs

Security Manager 6.5 version
SM 6.5.0.1054 - Initial release with no hotfixes or service packs
6.5.0.1181 - Service Pack 1 for Security Manager 6.5

Security Manager 6.0 Versions

6.0.0.194 - Initial release with no hotfixes or service packs
6.0.0.259 - Service Pack 1 for Security Manager 6.0
6.0.0.403 - Service Pack 2 for Security Manager 6.0
6.0.0.466 - Service Pack 3 for Security Manager 6.0
6.0.0.522 - Service Pack 4 for Security Manager 6.0

Security Manager 5.6 versions

5.60.0.231 - release version with no hotifxes or service packs
5.60.0.237 - Service Pack 1 for Security Manager 5.6

Security Manager 5.5 versions

5.50.0.158 - release version with no hotifxes or service packs

Security Manager 5.1 versions

5.10.0.80 - release version with no hotifxes or service packs
5.10.0.83 - Hotfix 45296
5.10.0.135 - Service Pack 1 for Security Manager 5.1
5.10.0.154 - Hotfix 48546

Security Manager 5.0 versions

5.0.0.132 - release version with no hotifxes or service packs
5.0.0.140 - Service Pack 1 for Security Manager 5.0




note
The Agents view in the Monitor Console under the Infrastructure Components folder also displays the release and service pack version number. However, this view does not show hotfix version numbers.

note
The database server does not have an EemWF.dll file that you can use to check the Security Manager version unless you have installed an agent or user interface on the database server computer.

Cause

It may be beneficial to determine the version of Security Manager which is installed.

Additional Information

Formerly known as NETIQKB48084