Web Console Chart page shows 'This control displays chart data.' (NETIQKB47577)

  • 7747577
  • 02-Feb-2007
  • 25-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

AppManager Web Console
AppManager Web Console Chart View

Situation

Web Console Chart tab does not offer NetIQChartConsole.exe download to new users.
The AMVersionChecker.cab is not available for download when the user clicks Web Console Chart page.
No other AppManger programs are installed on the user's machine.

Resolution

Edit the URLScan.ini file to add .cab in the AllowExtensions list.

To add .cab to the AllowExtensions section of the URLScan.ini file:

  1. Use a text editor to open \%windir%\system32\inetsrv\urlscanURLScan.ini.
  2. Update the AllowExtensions section as follows:

[AllowExtensions]

;
; Extensions listed here are commonly used on a typical IIS server.
;
; Note that these entries are effective if "UseAllowExtensions=1"
; is set in the [Options] section above.
;

.htm
.html
.txt
.jpg
.jpeg
.gif
.zip

; Note--extensions below required for AppManager

.asp
.css
.js
.exe
.png
.xml
.
; Needed for AppManager Chart Console / Version checker download
.cab

After editing the URLScan.ini file, the user can download and install AMVersionChecker.cab to make the NetIQChartConsole.exe file available for download, and then download and run  NetIQChartConsole.exe to install the AppManger Chart component.

Cause

This occurs because the URLScan.ini file on the user's computer does not have .cab in the AllowExtensions list.

Additional Information