The Application log on the Administration server reports that no Microsoft Exchange libraries exist, (NETIQKB47486)

  • 7747486
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 7.x

symptom
The Application log on the Administration server reports that no Microsoft Exchange libraries exist, but the tools are installed.

symptom
Cannot enable Microsoft Exchange support.

symptom
Error: 'No Exchange 2000 .dll's found.'

cause
The service account does not have rights to read a value from the registry. When the NetIQ Administration Service initializes, the service account will use the ExchangeServerAdmin value at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Setup to look for the Exchange dll's.  If the service account does not have rights to read this key, then DRA cannot determine where to look for Exchange dll's and will not be able to enable Exchange support. 

fix

To give the service account permission to read the registry:

  1. Click Start> Run.
  2. Enter regedt32.
  3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Setup.
  4. Right-click Setup > Permissions.
  5. Give the Service account Full Control.
  6. Restart the NetIQ Administration Service.


note

For information about how to verify all prerequisites for enabling Exchange support, see the NetIQ Knowledge Base article NETIQKB292: "How do I enable Microsoft Exchange 2000/2003 Mailbox support in Directory and Resource Administrator?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB292.  



Additional Information

Formerly known as NETIQKB47486