How do I prevent the NetIQ Administration Service from terminating after installing or uninstalling (NETIQKB47391)

  • 7747391
  • 02-Feb-2007
  • 12-Mar-2008

Environment

Directory and Resource Administrator 6.x
Directory and Resource Administrator 7.x
Directory and Resource Administrator 8.x

Microsoft Operations Manager

Situation

What are the known issues with having MOM installed on DRA servers?

How do I prevent the NetIQ Administration Service from terminating after installing or uninstalling the MOM agent?

What causes the NetIQ Administration Service to terminate after installing or uninstalling the MOM agent?

How does installing or uninstalling the MOM agent affect the NetIQ Administration Service?

How does installing or uninstalling the MOM 2005 hotfix affect the NetIQ Administration Service?

Error message is generated when trying to connect with the DRA client: 'Administration server cannot identify the user account, if you continue to experience the issue to contact the Administrator to synchronize the Administration servers and refresh the account cache'

The NetIQ Administration Service terminates after manually uninstalling the MOM agent from the Administration Server.

The NetIQ Administration Service terminates after applying a MOM 2005 hotfix on the Administration Server

Error: The registry sub-tree for UserInterface could not be setup for notifying for change.

Error: Unable to open DRAAdmins rule registry subkey.

The Mission Critical Software registry key or large chunks of it are missing.

Resolution

Workarounds:

  • If the Administration Server is a Secondary, remove the Administration Server from the MultiMaster set, uninstall Directory and Resource Administrator (DRA) including registry keys, re-install DRA and then re-add the Secondary back to the MultiMaster set. 
  • If the DRA server is a Primary, then promote a new DRA server to the Primary and rebuild the original Primary machine or if it is a stand-alone Primary, then restore the registry.
  • If the Registry on the Administration Server has been recently backed up or exported, it can be re-imported to restore the missing key.  To do so:
    1. Open REGEDIT on the backed up machine and browse to the HKLM\SOFTWARE\Mission Cirtical registry hive.
    2. Right-click the Mission Critical registry key and select Export.
    3. Save the file as "Mission Critcal" keeping the .reg extension.
    4. Copy the exported registry file to the DRA server you wish to restore.
    5. Launch REGEDIT on the DRA server and select FIle and Import.
    6. Browse to the location you copied the exported registry file to in step 4 and click Open.
    7. The restored registry file will be imported to the DRA server's registry.
    8. Reboot the DRA server.

The newest version of MOM (SCOM) no longer uses the Mission Critical registry keys.  For a permanent resolution for this issue, it is advised to only run SCOM or the SCOM Agent on DRA servers.

Cause

The cause of this issue is that certain instances of uninstalling MOM or applying a MOM hotfix/update deletes the Mission Critical Software Key in part or in whole. Older versions of MOM use the same Mission Critical registry keys that DRA utilizes. This also can result if MOM is upgraded to SCOM on the machine.  The upgrade process removes the MOM installation before installing SCOM.  Any uninstall process also may remove DRA registry keys.

Additional Information

Formerly known as NETIQKB47391

One hotfix that a customer reported as removing the Missioncritical Software key was the MOM 2005 hotfix 889054.