Resolution
goal
Why does the Account and Resource Management (ARM) console display incorrect RAS settings?
fact
Directory and Resource Administrator 7.5
symptom
The console displays incorrect RAS settings if the Assistant Admin does not have read permissions to the RAS fields.
symptom
The console displays incorrect RAS settings if the user does not have "View" powers.
symptom
Console wizards appear to fail to close themselves upon completion when creating new objects.
cause
The issue is due to some of the RAS properties are set to enabled by default.
fix
Why does the Account and Resource Management (ARM) console display incorrect RAS settings?
fact
Directory and Resource Administrator 7.5
symptom
The console displays incorrect RAS settings if the Assistant Admin does not have read permissions to the RAS fields.
symptom
The console displays incorrect RAS settings if the user does not have "View" powers.
symptom
Console wizards appear to fail to close themselves upon completion when creating new objects.
cause
The issue is due to some of the RAS properties are set to enabled by default.
fix
NetIQ Directory and Resource Administrator and Exchange Administrator version 7.5 Hotfix 47030.
This hotfix addresses the following usability issues in the Account and Resource Management (ARM) console:
- The console displays incorrect RAS settings if the user does not have "View" powers. This hotfix resolves this issue by not displaying any RAS settings for users that do not have "View" powers.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47382 - The console enables the "Set Primary Group" button on user property sheets even if the Assistant Administrator (AA) does not have "Set primary groups" power. This hotfix resolves this issue by disabling the "Set Primary Groups" button if the AA does not have the correct power.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47383 - DRA creates and displays custom user interface extension pages on user objects that are part of a Windows NT 4 domain even though NT 4 does not support custom user interface extension pages. This hotfix resolves this issue by disabling the ability to create custom user interface extension pages for any users, groups, and computers that are part of an NT 4 domain.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47384 - The console selects one or more checkboxes when you click in the blank space around checkboxes. This hotfix resolves this issue by limiting the clickable area for each checkbox to the checkbox and label only.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47385 - The console fails to display an hourglass icon after clicking Apply or OK on property sheets and Create wizards. This hotfix resolves this issue by displaying the hourglass.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47386 - The console cannot accept field names or values on a custom page that contain the characters "<" or ">". This hotfix resolves this issue by adding support for these characters.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47387 - Console wizards appear to fail to close themselves upon completion when creating new objects. This is d.
ue to the wizard not displaying an hourglass icon when waiting for the DRA server to complete the requested operation. This hotfix resolves this issue by displaying the hourglass icon.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47388
Note: This hotfix requires DRA version 7.5.
To download and install this hotfix, perform the following steps on each computer where you installed the DRA Account and Resource Management Console:
- Close all DRA user interfaces.
- Run the DRA75000_Hotfix47030.msi file.
This hotfix modifies the following files in the installation directory, by default C:\Program Files\NetIQ\DRA:
- NetIQ.DRA.Console.Accounts.dll
- NetIQ.DRA.Controls.dll
- NetIQ.DRA.Framework.dll
- NetIQ.DRA.ServerObjects.dll
- NetIQ.DRA.UIExtensions.dll
For more information, contact Technical Support at www.netiq.com/support.
.Additional Information
Formerly known as NETIQKB47382