Installation fails with error: 'The installation is < Registering type libraries>' and Error 1001 (NETIQKB47280)

  • 7747280
  • 02-Feb-2007
  • 28-Dec-2010

Environment

NetIQ Analysis Center 2.x

Situation

Installation fails with error: 'The installation is < Registering type libraries>' and Error 1001
error: '-1603 Fatal error during installation
Consult Windows Installer Help (Msi.chm) or MSDN for more information'
Symptom
** Error [NetIQETL] SQL Statement Error
Exception: System.Runtime.InteropServices.COMException (0x80045703): [SQL-DMO][Microsoft][ODBC SQL Server Driver][SQL Server]Ad hoc updates to system catalogs not recommended. Use the RECONFIGURE WITH OVERRIDE statement to force this configuration.

Resolution

Ensure that you have the DTC (Distributed Transaction Coordinator) enabled for Network access on each AC component server.

a. Connect to the server hosting the Analysis Center Data Mart component.
b. Go to Start > Control Panel > Add or Remove Programs.
c. Click Windows Components > Application Server > Details.
d. Select Enable network DTC access.
e. Click OK on both component screens to save the option set.
f. Repeat steps a-e on the server where the Analysis Center Data Warehouse component is installed.

Next, you can confrim the SQL system cataloges.  By default, SQL does not allow modifications directly to the system catalogs.  If this option is enabled, SQL errors will result and fail to complete execution of the database creation stored procedures.  In addition, sql accounts with special passwords may not be parsed correctly.

To modify the settings for system catalogs:

  1. Open SQL Enterprise Manager.
  2. Select the targeted AC SQL Server | Properties | Server Settings
  3. Clear the Allow modifications to be made directly to system catalogs check box.
  4. Click OK.
  5. Launch the Analysis Center installation.

If you are using special characters in the sql password, you may have to change the password to exclude special characters or place the password in double quotes (" ").

For more information, contact Technical Support at www.netiq.com/support.



Cause

The Allow modifications to be made directly to system catalogs option is enabled or SQL account has special characters (such as *) within the password.

Additional Information

Formerly known as NETIQKB47280