Operator Console stalls and pegs CPU to 99% with a blank screen. (NETIQKB47202)

  • 7747202
  • 02-Feb-2007
  • 21-Apr-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Operator Console stalls and pegs CPU to 99% with a blank screen.
Operator Console used to function and launch faster previously.
User Interface response is slow.
Poor console performance.

Resolution

Launch the console using an option that will avoid unneccessary access of the large tables, for example, netiq.exe /showmasterview. 

To view these options, open a command window and enter netiq /?

It may also help to open the Operator Console using the split-tree view. This can be selected from the Preferences menu and checking the Split-Tree view check box and restarting the Operator Console. This loads server objects into memory on demand rather than loading all objects when the console is opened and uses much less memory in larger environments.

Cause

One or more of the main tables in the Operator Console has such a high number of rows, possible tens of thousands. Accessing the data causes the Console performance to significantly diminish.

Additional Information

Formerly known as NETIQKB47202

To quickly check the number of rows and sizes of each of the key tables in the AppManager repository, use the Microsoft SQL Query Analyzer to run the query sp_spaceused against each table.