Chart Console does not display data. (NETIQKB46543)

  • 7746543
  • 02-Feb-2007
  • 08-Feb-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ Chart Console

Situation

Chart Vertical Legend has multiple zeros '0' displayed.

Resolution

AppManager charts have a built-in feature that allow the dynamic growth of Vertical Legends based on the Maximum value returned to the Chart.  If all the collected data returned is zero, then in some cases the legend will only show zeros and the zero value datapoints will not be displayed.

There are 2 methods to enable the AppManager Chart to display the zero values:

  1. Refresh the Chart within the Operator Console using the Chart refresh (Not the browser).
  2. Force the Chart settings to read a different value, then set back to the default legend:
    • Right-click on the Chart within the Operator Console and go to Properties.
    • When the Properties page appears, Vertical Maximum setting.
    • Change the setting from Auto to Manual and set the number to "10".
    • Click OK to return to the Operator Console.

Once in the Operator Console, your Chart should show all data points and values.

Cause

Chart legends were not updated to actual values (only showing zeros) and ignore displaying the 'zero' value datapoints.

Additional Information

Formerly known as NETIQKB46543