Action_RebootSystem Knowledge Script fails to restart AppManager Agent when Event occurs. (NETIQKB46369)

  • 7746369
  • 02-Feb-2007
  • 15-Feb-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Action_RebootSystem Knowledge Script

Situation

Event Message when Action_RebootSystem fails to restart AppManager Agent system: 'Action denied for ms xx.xx.xx.xx'

Short Message for failed Action_RebootSystem: 'Event ID [xxxxx] Local Action: Action not allowed'

Resolution

The Name(s) of the Management Servers must be entered in the AllowReboot Registry Key for the Action_RebootSystem to work properly:

  1. Specify the Action to run on a job that runs on the Agent system that you will to reboot.
  2. Specify the Action to run from the Managed Client (MC).
  3. Specify the NetIQ AppManager Client Communication Manager and NetIQ AppManager Client Resource Monitor services to run as an account with reboot privileges on the MC Agent system.
  4. Include the name of the MS system in a value in the HKLM | Software | NetIQ | AppManager | 4.0 | NetIQmc | Security | AllowReboot registry key. Note: This value is required. 
  5. Restart the NetIQ AppManager Client Resource Monitor for the new registry key to take effect.

Cause

On the AppManager Agent where this action runs, the registry value for HKLM | Software | NetIQ | AppManager | 4.0 | NetIQmc | Security | AllowReboot does not include the name of the primary management server.

The Action may be incorrectly set to run from a Management Server (MS).  This action may only be run from a Managed Client (MC).

Additional Information

Formerly known as NETIQKB46369

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.