Error: Cannot open cube 'vAMgeneric' (NETIQKB46096)

  • 7746096
  • 02-Feb-2007
  • 08-Feb-2011

Environment

NetIQ Analysis Center 2.x

Situation

Error: Cannot open cube 'vAMgeneric'

Resolution

The process to correct this issue require various technical steps.  Please contact NetIQ Technical Support with any questions prior to executing the steps below.

Analysis Center uses a Service Account in various locations and on different servers (when part of a multiple-server installation).  Verify the security requirements in the following steps:

  1. Verify the AC service account has the required permissions (see page 103 of the Analysis CenterGuide).
  2. Within the SQL Server, expand to the SQL Server | Management | SQL Server Agent | Jobs and verify these jobs:

    Analysis Center Installation
    Analysis Center (OLAP Processing)
    [DS_server_repository] ETL
    [DS_server_repository] Create Data Source Data marts

  3. In SQL Analysis Manager try to browse the data in the AMGeneric(1) cube and then the vAMGeneric(1) virtual cube in Analysis Manager to verify that data exists.
  4. Go to the following page on your server hosting the Web Services:

    http://localhost/acwebservice/acs.asmx?op=ExecuteMDX

    You will need to provide data for the following two parameters:

    conn: ACOLAP
    mdx: select {[Measures].[MetricMin]} on columns, {[Metric].[Description1].[AM Event Count]} on rows from vAMGeneric
    (or substitute any valid MDX statement already captured)

    This will verify the connectivity of the webservice to Analysis Services. It will produce some XML with a result set. If this doesn?t not work, then the Web Services cannot talk to Analysis Services, and implies permission/access issues ? either by adding the Impersonation Account to the local OLAP Administrators account on the Analysis Services server, or to go to the next step.

  5. Install Analysis Services on the web client machine, selecting DSO and AS Client Tools only.
  6. Verify the versions of SQL and the SQL Analysis Services service packs are the same.

Cause

The service account used by Analysis Center does not have access to required resources or the Analysis Services Client Tools is not installed on the Web Services server

Additional Information

Formerly known as NETIQKB46096