AppManager Operator Console has performance and behavioral issues. (NETIQKB45918)

  • 7745918
  • 02-Feb-2007
  • 29-Nov-2007

Environment

AppManager 6.0
AppManager 5.0.1

Microsoft Windows 2000 Server
Microsoft Windows Server 2003, Datacenter Edition
Intel Hyperthreading Enabled

Situation

AppManager Operator Console has performance and behavioral issues.
Periodically Monitoring Policy do not display the Knowledge Script Groups (KSGs). Closing and opening the Monitoring policy displays the KSGs.

AppManager Operator Console hangs at 'N' percent when closing.
AppManager Operator Console panes display slowly and/or appear gray.

Resolution

Consider the following steps to improve overall Console performance:

  1. Disable Hyperthreading.   Allows you to isolate the CPU functions to one instance. This can often improve performance immediately.  For more information, refer to the NETIQKB43812 article: How do I disable Intel's Hyperthreading Technology?.

  2. Disable VirusScan Realtime Scanning on the \Program Files\NetIQ folder to eliminate file locks and scan delay issues.

  3. Close the AppManager Console and delete the AppManager User's Console Cache folder. By default, the cache is located in \Program Files\NetIQ\AppManager\BIN\Cache\<AppManagerUser>.

  4. Reinstall the Windows Script Host on the AppManager Console Server.

    To download the install from microsoft, check at the following location: Windows Script Host 5.6.

  5. Acknowledge or delete some of your Closed Events to clear them from the Operator Console.

  6. Investigate the amount of Archive Data you currently retain within your AM Repository.  For more information, reference KB article: NETIQKB23612.

  7. Reset the SQL Memory allocation to use a Fixed amount of memory and add more memory to your SQL server: 
    1. Verify in Windows Task Manager that SQL is not using all of the allocated memory.  This could be the cause for resource contention.
    2. To verify memory utilization, open Windows Task Manager and identify the Memory Usage for the sqlservr.exe process.
    3. In Microsoft SQL Server> Enterprise Manager, select the server in the left pane.
    4. In the Action menu, click Properties.
    5. Click the Memory tab to verify if the server is configured to use a Fixed amount of memory. 
    6. Allocate more memory to the SQL server for the NetIQ operator console to function.
    7. Consider adding additional physical memory on the SQL server if the computer is at the maximum allocation.
    8. Restart the SQLServer service to ensure any currently used memory is released. Note: This step is optional.


Cause

Hyperthreading is enabled on the Appmanager Console Server.  The existing code is known to have problems running across a virtual processor environment.

Any Realtime scanning by Virus Scanning software can cause delays by locking the AppManager Operator Console cache folder, which makes this folder inaccessible to the AppManager application.

The AppManager Console Cache located in \Program Files\NetIQ\AppManager\Bin\cache\<AppManagerUser> may be corrupt.

Microsoft Visual Basic restrictions or problems on the AppManager Console such as the Windows Scripting Host.


Additional Information

Formerly known as NETIQKB45918

If your problems continue after confirming the steps above, reference the Related Solution (NETIQKB51120) for a hotifx targeted specifically for the Operator Console.