Newly installed Agents are grayed out in the console and Discovery jobs will not run on the agent. (NETIQKB45674)

  • 7745674
  • 02-Feb-2007
  • 21-Apr-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Agents are grayed out in the console, but Troubleshooter > Client... > Connectivity responds with correct Agent information but the agent remains grayed out in the Operator Console. Discovery jobs are stuck in Pending (Start) and do not complete.

Resolution

There are several network considerations for proper communications between the Management Server (MS) and targeted Agent. 

To troubleshoot and narrow the search for a communication failure consider:

  1. If pinging the Agent fails, the Agent computer maybe on a separate subnet where routing or DNS resolution is blocked
    When using ping -a from the Agent computer does not resolve the MS, DNS is not properly configured or blocked. 
    Note: You may have to configure the HOSTS files on each computer.
  2. If the Local Repository has the CMComm table with an incorrect IP address for the MS:
    1. Correct the IP address within the Local Repository.
    2. Configure HOSTS files for the Agent and MS.
    3. Cold start the Agent.
    4. Use the AMADMIN_CofigSiteComm KS to disable use of the IP address. 
  3. If the Local Repository has an empty CMComm table, the Agent could not resolve the MS to enter correct information.  See the options in step 5
  4. If an Agent on a separate network VLAN can communicate without error, the VLAN configuration is preventing network resolution or you must disable the default RPC settings during installation.

Cause

Custom network configurations prevent communication between the Management Server and targeted Agent. 

Additional Information

Formerly known as NETIQKB45674