ERROR: Counter not found (NETIQKB45558)

  • 7745558
  • 02-Feb-2007
  • 02-Jun-2011

Environment

NetIQ AppManager 7.x
NetIQ AppManager 6.0.x

Situation

ERROR: Processor or User counter not found (Proc: -1, User: -1). This error occurs when running any AppManager knowledge scripts on Microsoft Cluster Servers.
ERROR: Counter not found

Resolution

For more information about properly configuring a Microsoft Cluster configuration, see Microsoft Knowledge Base article 258750, Recommended private "Heartbeat" configuration on a cluster server, at http://support.microsoft.com/?id=258750.

Cause

This problem seems to occur due to a incorrect network binding order between the private network interface and the public interface on Microsoft cluster computers. AppManager uses a Win32API call to query performance counter data. This query is then passed through the private network of the Microsoft cluster, not the public network. Therefore, the return code from Win32 is -1, which means "not found".

Additional Information

Formerly known as NETIQKB45558