ERROR: 'Failed to initialize MAPI, hr=80004005. cannot run application.' (NETIQKB45360)

  • 7745360
  • 02-Feb-2007
  • 13-Dec-2007

Resolution

fact
Exchange Migrator 2.x

symptom
ERROR: 'Failed to initialize MAPI, hr=80004005. cannot run application.'

symptom
An error occurs when running EMProfileUpdate.

cause
Microsoft Outlook is not the default mail client on the workstation.

fix

To use the Control Panel to specify Microsoft Outlook as the Windows default email client:

  1. In the Control Panel, select Internet Options.

  2. On the File menu, click Open.

  3. On the Programs tab, select Microsoft Outlook from the Email list.

If you cannot use this procedure or performing the procedure does not resolve this issue, you can modify the Windows registry to make Microsoft Outlook the default email client.



fix

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.Define the following registry key to tell EMProfileUpdate to use Microsoft Outlook as the default mail client.

To use the Windows Registry to specify Microsoft Outlook as the Windows default email client:

  1. Open the Windows Registry Editor.

  2. Navigate to HKLM > Software > Microsoft > Windows Messaging Subsystem > MSMAPIApps.

  3. Create a Registry entry with the following characteristics:

    • ValueName: EMProfileUpdate.exe
    • ValueType:  [REG_SZ]
    • Value: "Microsoft Outlook"
  4. Close the Registry.

You can propagate this key using an Active Directory Group Policy or a logon script.



Additional Information

Formerly known as NETIQKB45360