Report Server Status shows a red X. (NETIQKB45325)

  • 7745325
  • 02-Feb-2007
  • 16-Mar-2011

Environment

NetIQ Analysis Center 2.x

Situation

Analysis Center generates reports and create subscriptions, but the Report Server component is not in a Healthy State.

Report Server Status shows a red X.

Resolution

If the DE is not installed, but the AC assemblies are present in the RS install folder, use the following steps to configure the DE: 
  1. Close any Analysis Center (AC) consoles.
  2. Verify the AC assemblies are in the RS folder. The default RS install folder is typically \Program files\microsoft sql server\MSSQL\ReportingServices\ReportServer\bin.
  3. Browse to the command line for the NQACDataExtenstion.dll to re-install the DE with the following command:

    InstallUtil NQACDataExtension.dll

    Note: InstallUtil.exe is a .NET component usually found in the following path: \WinNT\Microsoft.Net\Framework\v1.1.4322.
  4. Restart the AC Console.
  5. Go to your AC Enterprise screen and verify the state of your Report Server.
  6. Reboot your Analysis Center server

Cause

The Web Console checks if the Analysis Center Data Extension (DE) is installed. When the DE is installed, the Report Server (RS) keeps a reference to the AC data extension in its RSReportServer.config file.

Additional Information

Formerly known as NETIQKB45325

The six Analysis Center assemblies that AC copies to the \Program Files\microsoft sql server\MSSQL\ReportingServices\ReportServer\bininstall folder are:

          NQACDataExtension.dll
          NQAC.dll
          NQACDBConnector.dll
          NQACLib.dll
          NQACShared2.dll
          NQExslt.dll
          NQRCLib2.dll