RPC Error = 5 when attempting to connect to NetIQ AppManager client (NETIQKB44683)

  • 7744683
  • 02-Feb-2007
  • 21-Jun-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.x
Microsoft Windows XP Professional
Microsoft Windows XP Service Pack 2

Situation

RPC Error = 5 when attempting to connect to NetIQ AppManager client

How do I prevent the ERROR: RPC Error = 5 error when establishing a connection to a client using RPC tools?

How do I prevent the ERROR: RPC Error = 5 client connection error from occuring?

What causes an ERROR: RPC Error = 5 client connection error?

How can Windows Firewall settings affect my use of RPC-driven tools?

Resolution

NetIQ can provide steps for correcting this issue, based on information available in the following Microsoft KB Article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;873183

Should you need more detailed AppManager-specific instructions, please contact NetIQ Technical Support and refer to this KB article (NETIQKB44683).

Cause

Service Pack 2 for Microsoft Windows XP adds new Windows Firewall features and configurable settings that may prevent RPC-based communications from successfully functioning.  Some of these settings may affect RPC-based communications even if the Firewall itself is set to "OFF".

Additional Information

Formerly known as NETIQKB44683