How do I identify and remove expired licenses when the Discovery_NT job fails with 'License has expired'. (NETIQKB44448)

  • 7744448
  • 02-Feb-2007
  • 16-Feb-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

How do I identify and remove expired licenses when the Discovery_NT job fails with 'License has expired'.
Discovery_NT fails with 'License has expired'.

Error: 'License has expired' occurs when attempting to discover Microsoft Windows servers.

AppManager License Manager shows only current and non-expired licenses.

Current licenses are available.

Resolution

To resolve this issue, remove the expired licenses from License Manager and the LicenseSum table.

Warning:   Before proceeding with the following steps, please ensure a proper, full backup of the Repository server has been made.

1.  Open License Manager and delete any expired licenses.
2.  Open SQL Query Analyzer and select the Repository to run queries against.
3.  Run the following query which will delete all expired licenses:

delete from LicenseSum where expiration = 2811

4.  Re-run the Discovery_NT job.

Cause

Discovery_NT is using an expired license, instead of a current and active license, in the LicenseSum table.  A query against the LicenseSum table within the Repository shows numerous expired licenses (expiration value of 2811).  These expired licenses do not appear in the AppManager License Manager. 

Additional Information

Formerly known as NETIQKB44448

To identify all expired licenses in the LicenseSum table, perform the following query:

select * from LicenseSum where expiration = 2811

Any license in the LicenseSum table with a Quantity of 2811 has 0 licenses associated with it and the license is no longer valid.