Database, SQL, PoolManager, and/or Java connection errors are received. (NETIQKB42547)

  • 7742547
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
VigilEnt Security Manager 4.x

symptom
Database, SQL, PoolManager, and/or Java connection errors are received.

symptom
Error: 'VSS: Cannot connect to the VigilEnt database'.

symptom
Error: '[PoolManager] Failed to get database connection!'

symptom
Error: 'com.inet.tds.SQLException: Connection refused: connect'

symptom
Error: 'java.net.ConnectException: Connection refused: connect'

cause

The SQL Server service is not started on the VigilEnt Security Manager machine. There are several possible causes for the SQL Server service to be stopped:

  1. The service was stopped manually.
  2. The SQL service account has been changed.
  3. The SQL service account password has been changed.


fix

On the VigilEnt Security Manager machine, attempt to restart the SQL Server service using one of the following:

  • The Services applet in Computer Management.
  • The SQL Server Service Manager located on the taskbar.

If the service will not start, verify the password and account listed on the properties of the SQL Server Service.



Additional Information

Formerly known as NETIQKB42547