Windows Agent is unable to communicate with the MS Server once SP2 is added to Microsoft Windows XP (NETIQKB42480)

  • 7742480
  • 02-Feb-2007
  • 17-Apr-2012

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Microsoft Windows XP Service Pack 2

Situation

Windows Agent is unable to communicate with the MS Server once SP2 is added to Microsoft Windows XP
Managed Client is unable to communicate with the Management Server when Microsoft Windows XP Service Pack 2 is installed.
Error: 'Server unavailable. RPC_STATUS=1722' when using the Client Communication Manager Troubleshooter.
NetIQccm is unable to communicate with the NetIQms.
Agent icon is gray or dimmed in the Operator Console.

Resolution

To resolve this issue, please perform the following steps on the machine running Microsoft Windows XP Service Pack 2. These steps are required even if the Windows Firewall is set to Off:

  1. Click Start > Programs > Control Panel > Windows Firewall.

  2. On theExceptions tab, add the following ports and programs:

    Add port named NetIQccm 9999 for TCP port 9999.
    Add port named NetIQmc 9998 for TCP port 9998.
    Add program <path to>NetIQ\AppManager\bin\NetIQccm.exe.
    Add program <path to>NetIQ\AppManager\bin\NetIQmc.exe.

  3. On the Advanced tab, click Settings... for the Local Area Connection.

  4. On theAdvanced Settings > Services tab add the following services:

    • Add port 9999 named NetIQccm 9999, and:
      • Name or IP address of the computer hosting the service: 127.0.0.1 (local host)
      • External port number for this service: 9999 (TCP)
      • Internal port number for this service: 9999 
    • Add port 9998 named NetIQmc 9998, and:
      • Name or IP address of the computer hosting the service: 127.0.0.1 (local host)
      • External port number for this service: 9998 (TCP)
      • Internal port number for this service: 9998

         
  5. On the ICMP tab, check the Allow incoming echo request check box, which adds computer to the Operator Console.

  6. From the Windows Desktop, click Start > Run.

  7. In the Open field, type regedit and click OK.

  8. Navigate to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT.

  9. Look for sub-key RPC. If this key does not exist, go to step 10. If this key exists, click it and skip to Step 12.

  10. Click  Edit > New > Key.

  11. While the new key is selected, type RPC, and then press Enter.

  12. Go to  Edit > New > DWORD Value.

  13. Type RestrictRemoteClients, and then press Enter.

  14. Click  Edit > Modify.

  15. In the Value data box, type 0 (zero), and then click OK.

  16. Restart the operating system so that the new registry setting takes affect. You may need to remove and re-add the system to the AppManager operator console.

Cause

This problem occurs if Microsoft Windows XP Service Pack 2 is applied on the agent machine.  Microsoft Windows XP Service Pack 2 incorporates a firewall into the operating system and restricts RPC communications with remote systems.

Additional Information

Formerly known as NETIQKB42480

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.