AMADMIN_AgentInstall Knowledge Script fails with multiple errors. (NETIQKB42270)

  • 7742270
  • 02-Feb-2007
  • 21-Jul-2010

Environment

NetIQ AppManager 6.x
Microsoft Windows 2003 Server

Situation

AMADMIN_AgentInstall Knowledge Script fails with multiple errors.


ERROR: 'CreateProcessAsUser failed, error code = 1058' is returned.

ERROR: 'RPC error code 1726' is returned.

ERROR: 'Failed to copy distribution files over to \\target_server_name\C$\Temp\AgtInst\" is returned.

Resolution

In order to resolve the above described issue, please verify the following:

  • The account specified in the AMADMIN_AgentInstall Knowledge Script has permissions to the share where the installation files are located.
  • The UNC path and the share name are valid.
  • There are no spaces in the UNC path.
  • The account has administrative privileges on the target machine where the service is being installed.
  • The Remote Registry Service is started and not disabled.
  • The Secondary Logon Service  is started and not disabled.

Cause

The above error message may occur due to any of the following reasons:

  • The account specified does not have permissions to the share specified in the UNC path which include the setup program.
  • The UNC path and\or the share name is invalid.
  • The account does not have permissions to the target machine.
  • The Remote Registry Service is not running.
  • The Secondary Logon Service is not running.

Additional Information

Formerly known as NETIQKB42270

Microsoft Windows 2003 provides a options for "logon as secondary user" and "remote registry service".  These services enable AppManager to start our installation processes under alternate credentials. If these options are disabled on the local machine or via a Group Policy, this type of logon access will be unavailable and the installation will fail with various error messages

If you need further assistance with the subject matter discussed in this Knowledge Base Article, please contact NetIQ Technical Support.