Public Folder for charts is not present after I upgraded to AppManager 6.0. (NETIQKB42144)

  • 7742144
  • 02-Feb-2007
  • 24-Mar-2011

Environment

AppManager 6.0
AppManager 6.0.x
Chart Console

Situation

Public Folder does not display in Chart Console.

When the View and edit charts in public folder right is assigned to any roles that existed before the upgrade to AppManager 6.0, the change is not saved after exiting the Security Manager Console.

Resolution

WARNING:  The following solution involves direct modification of data in the AppManager repository. Improper execution may result in a loss of data or functionality in the product. Ensure you have a full repository backup before using these steps. Contact NetIQ Technical Support if you need any assistance.

To resolve this issue:

  1. Back up the repository.
  2. In SQL Query Analyzer, run the following commands to give the View permission to Administrator, Read Onlyuser, and Stand user:
    INSERT INTO dbo.SRoleRight (RoleID, RightID,ViewID,Value,GroupID)
    VALUES (1,13002,-1,1,13000)
    INSERT INTO dbo.SRoleRight (RoleID, RightID,ViewID,Value,GroupID)
    VALUES (2,13002,-1,1,13000)
    INSERT INTO dbo.SRoleRight (RoleID, RightID,ViewID,Value,GroupID)
    VALUES (3,13002,-1,1,13000)


  3. Launch the Chart Console.

If the Public Folder is visible, the issue is resolved.  

If the Public Folder is not visible after running the previous commands, the existing charts in the blob table might be corrupted. To resolve this issue you have two options. The first is more complex and will result in a loss of all Charts in the public folder, but will keep all other charts. The second will result in the loss of all charts in the chart console.

To resolve the issue and lose all charts in the Public Folder:

  1. Close all AppManager Chart Consoles.
  2. In SQL Query Analyzer, run the following command to get the entry for the public folder, replacing qdb_server_hostname with the hostname of the SQL Server the repository is on:

    SELECT * from blob WHERE comment = 'Charts_<qdb_server_hostname>\QDB'

  3. If the query does not return a result, go to step 5.
  4. If the query returns one result, make note of the blobid and run the following query:

    DELETE from blob WHERE blobid = <blobid>

  5. Launch the chart console and log on using the SA SQL Server account.
  6. In the Chart Console, create a chart in the public folder.
  7. Log off from the Chart console, and the public folder will now be viewable to all who have rights.

To resolve the issue, but lose all charts:

  1. Close all AppManager Chart Consoles.
  2. In SQL Query Analyzer, run the following command to get the list of charts in the Chart Console:

    select * from blob

  3. Run the following command to remove all charts in the blob table. Leave the row with the NULL comment. Do not modify it or delete it.

    Warning: Running the following SQL query will delete all users' charts. The charts will have to be recreated.

    DELETE from blob WHERE comment LIKE 'Charts_%'


Cause

During the upgrade from AppManager 5.01 to AppManager 6.0, the permission record for the public folder in the Chart Console is not inserted into the SRoleRight table in the AppManager repository. Security Manager cannot save the user settings of the Chart Console Public Folder to the AppManager repository.

Additional Information

Formerly known as NETIQKB42144