Non US date fields are showing blank in reports. (NETIQKB41916)

  • 7741916
  • 02-Feb-2007
  • 24-May-2007

Resolution

fact
NetIQ Vulnerability Manager 5.0

fact
NetIQ Vulnerability Manager 5.5

symptom

Non US date fields are showing blank in reports.



symptom
I can't see the dates in my report.

cause

Due to various date formats around the world, some dates may appear as blank in different reports.  The date is being calculated as a date instead of a string, which is how the report sorts the data.



fix

To change the way the date column is formatted, follow the instructions below:

    1. On the Core Services computer, browse to \Program Files\NetIQ\Vulnerability Manager\VSM and make a backup copy of the report_column_types file.
    2. Open the report_column_types file.
    3. Put in all new entries immediately under the line: //Column types for reports.
    4. Create an entry for each specific date field that appears blank in the report.
    5. For the Last Logon Date, use the following key strokes:
      • TypeGENERAL.
      • Press the Tab key.
      • Type Last Logon Date.
      • Press the Tab key.
      • Type string.
        • The tab character is interpreted as the field delimiter in this file. Spaces can be used inside the report column field name being entered into this file.  Just ensure that tabs are used as the delimiter.
    6. Save the file.
    7. In the product console, go to the Completed jobs folder and open the report in question.

  

.


note

Any sorting done once the format is changed to a string value will result in a string sort being instead of a date sort.  The sort will not consider the date as a numeric value but a character value. The file report_column_types holds entries for any field/report column that may need to have an alternate format used in its display.



Additional Information

Formerly known as NETIQKB41916