Error: 'Core cannot connect to database.' received when logging into NetIQ Vulnerability Manager. (NETIQKB41838)

  • 7741838
  • 02-Feb-2007
  • 22-Aug-2007

Resolution

fact
NetIQ Vulnerability Manager 5.0

fact
NetIQ Vulnerability Manager 5.5

symptom
Error:  'Core cannot connect to database.' received  when logging into NetIQ Vulnerability Manager.

symptom

Error message in core.log file by default located under \Program Files\NetIQ\Core Services\Log:

2004-08-02 12:39:45,593  ERROR [main] [PoolManager] Failed to get database connection!
com.inet.tds. SQLException: sql servername\ pipe\sql\query (The system cannot find the file specified)



cause
Use Windows Authentication has been enabled in the NetIQ Vulnerability Manager Core Services Configuration Utility and the VigilEnt database is on a separate server running Microsoft SQL.

fix

When specifying Core Services to use Windows authentication to communicate with the VigilEnt database and the database is on a separate server running Microsoft SQL, the following criteria must be met:

  • The NetIQ Core Services service must be running under the credentials of an administrator on the Microsoft SQL server.  To change the NetIQ Core Services service account, please refer to NETIQKB41844 on how to change the Vulnerability Manager service account.
  • Named Pipes must be enabled on the Microsoft SQL server.  Please follow the steps below on how to enable Named Pipes on the MS SQL server:
    1. Launch SQL Server Enterprise Manager.
    2. Right-click on the Microsoft SQL server located in the left tree pane and select Properties.
    3. Under the Generaltab, click Network Configuration....
    4. In the General tab, select Named Pipes and click Enable.
    5. Click OK.
    6. Click OK again.


Additional Information

Formerly known as NETIQKB41838