Error: 'Can't find counter for object\counter\instance' returned by General_Counter Knowledge Script (NETIQKB41371)

  • 7741371
  • 02-Feb-2007
  • 08-Dec-2016

Environment

NetIQ AppManager Suite 8.x
NetIQ AppManager Suite 9.1

Situation

Error: 'Can't find counter for object\counter\instance' returned by General_Counter Knowledge Script.
Custom performance counter is not detected by General_Counter Knowledge Script.
Custom performance counter was installed and is visible in Perfmon.

Resolution

Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system.  NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved.  Make sure that you backup your Registry prior to making any changes.

To address Perfmon counter issues:

  1. Reboot the computer where the installed counter is loaded (particularly if the computer has not been rebooted since the counter was installed).
  2. Verify the counter was loaded using the typeperf command. At a command prompt type the following command:
    typeperf -q -o %UserProfile%\Desktop\PerfMonCounters.txt
  3. Open the Registry Editor and verify the counter appears under the following registry key:

    HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/<Servicename>/Performance

Values such as the following are displayed in the right pane related to the service:

First Counter
Last Counter
Open
Close
Collect

If the Performance key and related values are not visible, you need to re-install the counter using the lodctr.exe command and reboot the system.

 

It is also possible that you need to rebuild the performance counters and verify they have not been disabled. Please reference the following Microsoft KB articles.

Cause

Microsoft performance counters are missing or corrupt.

Additional Information

Formerly known as NETIQKB41371