Error: 'Failed to register agent'. (NETIQKB40998)

  • 7740998
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Agent for NetWare 1.3.2

fact
NetIQ Vulnerability Manager

symptom
Error: 'Failed to register agent'.

change
Upgraded the VigilEnt Security Agent for NetWare to Service Pack 2 (SP2).

cause
The cause for this issue is unknown at this time.

fix

If you experience this issue, use the following procedure to register the NetWare agent in the NetIQ Vulnerability Manager (VM) console:

  1. Add the managed system to the VM console.
  2. Execute \Program Files\PentaSafe\VSA\start.bat on the NetWare agent machine.
  3. Register the agent in VM by right-clicking the system in the NetWare Managed Group.
  4. Execute \Program Files\PentaSafe\VSAN\stop.bat, or just close the start.bat command window on the NetWare agent machine.
  5. Re-register the agent in VM.  (This operation will fail.)
  6. Restart the NetIQ NetWare Agent service on the NetWare agent machine.
  7. Re-register the agent in VM.  (Registration will be successful at this time.)


Additional Information

Formerly known as NETIQKB40998