Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Compaq/HP Insight Management Agent
NetIQ AppManager 7.0.x
Compaq/HP Insight Management Agent
Situation
Dell or CIMKnowledge Scripts are generating 'SNMP Not Functional' and 'Failed to get OID' errors.
Error: 'Failed to get OID' is received when running Dell or CIM Knowledge Scripts.
Error: 'Failed to get OID' is received when running Dell or CIM Knowledge Scripts.
Resolution
To resolve this problem, perform the following steps on the agent computer:
- Open Services.
- Select the SNMP Service.
- Right-click and select Properties.
- Click on the Security tab.
- Check the Accept SNMP packets from these hosts or Accept SNMP packets from any host option.
- If you checked the Accept SNMP packets from these hosts, click the Add button.
- Specify the name or IP address of the agent computer.
For more troubleshooting steps, please refer to the following article: NETIQKB46308
Cause
The error messages are generated if the Accept SNMP packets from these hosts field is not set to allow the agent to query itself.
Additional Information
Formerly known as NETIQKB40950
The SNMP Community String for the AppManager Agent computer must match with the rest of the community. The Community String name is case-sensitive.