Error: 'The page cannot be found' when attempting to launch the Admin and/or the Self-Service Site (NETIQKB39084)

  • 7739084
  • 02-Feb-2007
  • 05-Oct-2011

Environment

Secure Password Administrator 1.0

Situation

Error: 'The page cannot be found' when attempting to launch the Admin and/or the Self-Service Site

Attempting to launch the Secure Password Administrator Admin and/or the Self-Service Site results in the following error message:

The page cannot be found.

HTTP 404 - File not found.

Internet Information Services

Resolution

In order to resolve this error message, please ensure that the IIS Admin Service and the World Wide Web services are running on the IIS server running Secure Password Administrator.  Also ensure that the NetIQ_Secure_Password_Administrator virtual directory exists.

If the services are running and the virtual directory exists, but no users are able to connect to the Admin and/or the Self-Service Site, the port used by Secure Password Administrator may be in use or assigned to another application.  By default Secure Password Administrator uses port 8007.

To verify which port is being used by Secure Password Administrator, open the Server.xml file located on the machine running the NetIQ Secure Password Administrator Service in the \Program files\NetIQ\SPA\Conf directory and towards the end of the file the following line will state the port number:

<Parameter names-"port" value="port_number"/>

If the port number specified in the Server.xml file is being used by another application on the IIS server, or is blocked, please perform the following steps in order to change configure Secure Password Administrator to use a different port instead:

  1. Stop the NetIQ Secure Password Administrator.
  2. Launch Windows Explorer on the server running the NetIQ Secure Password Administrator Service.
  3. Browse to the \Program files\NetIQ\SPA\conf directory.
  4. Select and right-click the Server.xml file and open the file in Notepad.
  5. Edit the following line by changing the assigned port number to the desired port number.  For example in the following the port number has been set to 8008.


    <Parameter names-"port" value="8008"/>

  6. Close the Server.xml file and save the changes.
  7. Select and right-click the works.properties.xml file and open it in Notepad.
  8. Edit the following line by changing the assigned port number to the desired port number.  For example in the following the port number has been set to 8008.


    worker.ajp13.port=8008

  9. Close the works.properties.xml file and save the changes.
  10. Start the NetIQ Secure Password Administrator.
  11. Restart the IIS Admin Service.


Cause

The above error message will be returned due to any of the following reasons:

  • IIS Admin Service and the World Wide Web services are not running.
  • The SPA virtual directory (NetIQ_Secure_Password_Administrator) does not exist.
  • The port used by SPA is in use by another application.  Typically SPA uses port 8007.

Additional Information

Formerly known as NETIQKB39084