Unable to collect firewall performance data for Cisco Secure PIX Firewall. (NETIQKB38364)

  • 7738364
  • 02-Feb-2007
  • 07-Jul-2008

Resolution

fact
Security Manager 4.20

fact
Security Manager 4.50

fact
Security Manager 4.60

fact
Security Manager 5.00

fact
Security Manager 5.1

fact
Security Manager 5.5

symptom
Unable to collect firewall performance data for Cisco Secure PIX Firewall.

symptom
Script failure while monitoring Cisco Secure PIX Firewall.

symptom
Alert: 'Collect firewall performance data script failed.'

symptom
Incorrect Cisco Secure PIX account and password.

cause
This alert is most likely caused by a permissions issue.  If the Collect Firewall Performance Data (Customize) rule is enabled, the Collect Firewall Performance Data script runs every 15 minutes and uses the PIX administrator name and password to establish a connection to the firewall.  These credentials are specified as parameters in the script.  If the credentials are not specified or are incorrect, the script fails.

fix

To change the credentials used by the Collect Firewall Performance Data script :

  1. Start the Development Console.
  2. In the left pane, expand  Processing Rule Groups > Cisco Secure PIX Firewall > PIX Firewall Shared Rules.
  3. Click Event Processing Rules.
  4. In the right pane, click Collect Firewall Performance Data (Customize).
  5. On the Action menu, click Edit.
  6. On the Responses tab, click Cisco Secure Pix Firewall - Collect Firewall Performance Data, and then click Edit.
  7. In the Script parameters field, click the parameter you need to edit, and then click Edit Script Parameters.
  8. Type the correct value in the Value field, and then click OK.
  9. Repeat steps 6-7 until you have finished correcting the credentials in the script parameters.
  10. Click OK.
  11. Click OK.
  12. In the left pane, click Configuration.
  13. On the Action menu, click Force Configuration Changes Now.


Additional Information

Formerly known as NETIQKB38364