Environment
NetIQ AppManager Agent 6.x
NetIQ AppManager Agent 7.0.x
NetIQ AppManager Agent 7.0.x
Situation
AppManager Agent fails to forward Events for any job running on a specific Agent.
MCTrace.log shows Events being forwarded to the Mapque file, but no Events are being sent back to the QDB.
No Actions are being triggered.
MCTrace.log shows Events being forwarded to the Mapque file, but no Events are being sent back to the QDB.
No Actions are being triggered.
Resolution
To resolve this issue, follow these steps:
- Stop the NetIQ AppManager Client Communication Manager service (NetIQccm) and the NetIQ AppManager Client Resource Monitor service (NetIQmc) on the troubled agent.
- Delete the contents of the <install path>\NetIQ\AppManager\dat\mapque directory.
- Once deleted, cold start the NetIQ AppManager Client Communication Manager service (NetIQccm) with the '-oa' parameter and the NetIQ AppManager Client Resource Monitor service (NetIQmc) with the '-o' parameter.
Cause
This behavior indicates that the NetIQmc service and the NetIQccm service may not be looking at the same MAPQUE files, or the MAPQUE file is corrupt. The MAPQUE is a local cache on the agent that facilitates communication between the two agent services.
Additional Information
Formerly known as NETIQKB38125