Resolution
VigilEnt Security Manager 4.0
fact
VigilEnt Security Agent for Oracle 2.0
symptom
Error: 'The agent monitoring this endpoint has not been registered' when attempting to register agent.
cause
VigilEnt Security Agent for Oracle 2.0 is not configured to allow communication with VigilEnt Security Manager 4.0. (By default, the VigilEnt Security Agent for Oracle 2.0 is configured to communicate with VigilEnt Security Manager 4.1.)
fix
To allow communication between VigilEnt Security Agent for Oracle 2.0 and VigilEnt Security Manager 4.0, the VSMDBAgent.options file needs to be modified as follows:
- Go to the VigilEnt Security Agent for Databases 2.0 install directory:
\Program Files\NetIQ\VigilEnt Security Agent for Databases
- Save a backup copy of the VSMDBAgent.options file as VSMDBAgent.options.original.
- Using a text editor, make the following changes to the VSMDBAgent.options file:
Original content of VSMDBAgent.options file
#server/port=1622
server/concurrency=10
server/scanms=100
server/socket/timeouts=30
server/socket/backlog=50#server/listener/001/name=vigilent
#server/listener/001/port=8622
#server/listener/003/name=ssl
#server/listener/003/port=1651
#server/listener/003/provider=com.pentasafe.mk.net.VssSocketFactory
#server/listener/003/verify=true
#server/listener/003/availablepatch=trueserver/listener/001/name=ssl
server/listener/001/port=1651
#server/listener/001/provider=com.pentasafe.mk.net.VssSocketFactory
server/listener/001/provider=com.pentasafe.mkx.net.ssl.VsslSocketFactoryA
server/listener/001/availablepatch=true
server/listener/001/sigreq=trueclient/socket/timeouts=120
threadpool/size=30
threadpool/reaperm=60
threadpool/threadagem=5report/fastreturn/enabled=false
Content of VSMDBAgent.options file after changesNote: You should modify the VSMDBAgent.options file exactly as it appears below, with no extra spaces or other characters. Also, be sure a backup of the original file was made (as suggested in Step 2 above) so that changes can be undone, if necessary.
#server/port=1622
server/concurrency=10
server/scanms=100
server/socket/timeouts=30
server/socket/backlog=50server/listener/001/name=vigilent
server/listener/001/port=8622
server/listener/003/name=ssl
server/listener/003/port=1651
server/listener/003/provider=com.pentasafe.mk.net.VssSocketFactory
server/listener/003/verify=true
server/listener/003/availablepatch=true#server/listener/001/name=ssl
#server/listener/001/port=1651
#server/listener/001/provider=com.pentasafe.mk.net.VssSocketFactory
#server/listener/001/provider=com.pentasafe.mkx.net.ssl.VsslSocketFactoryA
#server/listener/001/availablepatch=true
#server/listener/001/sigreq=trueclient/socket/timeouts=120
threadpool/size=30
threadpool/reaperm=60
threadpool/threadagem=5report/fastreturn/enabled=false
note
Please contact NetIQ Technical Support if you have any additional questions about this issue.