Netiq Security Checks are not installed after upgrading from VigilEnt Security Manager 3.0 SR2 to 4. (NETIQKB37201)

  • 7737201
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Manager 4.1

symptom
Netiq Security Checks are not installed after upgrading from VigilEnt Security Manager 3.0 SR2 to 4.1.

cause
The cause of this issue is due to the 8dot3 naming creation being disabled on the VigilEnt Security Manager (VSM) server.  In order to install the Netiq Security Checks during the VSM installation, the batch file scpopulate.bat is called.  The batch file contains a line pointing to the full path 'C:\Program Files\NetIQ VigilENt Security Manager\VSS\jre\bin\java.exe.'  Since the full path file name contains spaces in it, withouth double quotes around it, the execution of the java.exe will fail.  With the 8dot3 naming creation enabled, all of the long folder names are converted to a short name without a space in it.  This will allow for a successful execution of the java.exe command.

fix

To enable 8dot3 naming creation on the VSM server, please follow the steps below:

  1. Launch Regedit logged in as an administrator on the VSM server.
  2. Browse to the following registry key: 

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem and locate the REG_DWORD NtfsDisable8dot3NameCreation
  3. For the value, change the 1 to a 0.  This will enable 8dot3 naming creation on the VSM server.
  4. Reboot or schedule a reboot of the server in order for the change to take effect.


Additional Information

Formerly known as NETIQKB37201