Resolution
fact
Exchange Migrator 2.x
symptom
A recently installed program may cause Microsoft Office or other e-mail-enabled programs to function improperly.
symptom
Outlook can resolve this conflict without affecting the program that originally caused the problem. Do you want Outlook to resolve this problem?
cause
When installing Exchange Administrator and/or Exchange System Manager on the Exchange Migrator console (or any machine that has Exchange System Manager and Microsoft Outlook installed), the 1.x version of MAPI32.dll installed by Outlook into the \Winnt\System32 folder is replaced with the 5.x/6.x version necessary for the Exchange tools to function correctly.
fix
Follow these steps to resolve:
note
Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.
note
If you are unable to make the change to the registry of the Exchange Migrator console, the alternative is to make sure anyone who logs into the Exchange Migrator console and launches Outlook clicks "No" when prompted with this message.
note
Exchange Migrator 2.x
symptom
A recently installed program may cause Microsoft Office or other e-mail-enabled programs to function improperly.
symptom
Outlook can resolve this conflict without affecting the program that originally caused the problem. Do you want Outlook to resolve this problem?
cause
When installing Exchange Administrator and/or Exchange System Manager on the Exchange Migrator console (or any machine that has Exchange System Manager and Microsoft Outlook installed), the 1.x version of MAPI32.dll installed by Outlook into the \Winnt\System32 folder is replaced with the 5.x/6.x version necessary for the Exchange tools to function correctly.
fix
Follow these steps to resolve:
- Make sure the MAPI32.dll version in the Winnt\System32 directory is 6.5762.3 or later (5.2650.12 or later if you are only migrating to Exchange 5.5).
- If it is not, either reinstall the Exchange 5.5/2000 SP, or copy the MAPI32.dll from the \Program Files\Exchsrvr\bin directory and replace the 1.x version in the Winnt\System32 directory.
- Add the following registry value, which will suppress the pop-up message:
- Open Regedit.
- Browse to the following registry key:
- HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook (for Outlook 2000)
- HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook (for Outlook XP)
- HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook (for Outlook 2003)
- On the Edit menu, click New, and then click DWORD Value.
- Name the new DWORD Value, FixMAPI.
- On the Edit menu, click Modify.
- Click Decimal. In the Base section, type 0 (zero) in the Value Data box, and then click OK.
- On the Registry menu, click Exit.
note
Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Make sure that you backup your Registry prior to making any changes.
note
If you are unable to make the change to the registry of the Exchange Migrator console, the alternative is to make sure anyone who logs into the Exchange Migrator console and launches Outlook clicks "No" when prompted with this message.
note
For more information please see the following Microsoft Knowledge Base articles:
- XGEN: Microsoft Does Not Recommend Installing Exchange Server 5.5 and Outlook 2000 or Later on the Same Computer
http://support.microsoft.com/default.aspx?scid=kb;en-us;313889 - XCCC: Microsoft Does Not Recommend Installing Exchange 2000 Server and Outlook 2000 or Later on the Same Computer
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B266418Â - OL2000: Startup Error Indicates Problem with Recently Installed Program
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B256946 - OL2002: You Receive an Error Message About a Recently Installed Program When You Start Outlook 2002
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B287570Â - Problems If There Is a File Conflict with the MAPI File on Your Computer
http://support.microsoft.com/default.aspx?scid=kb;en-us;813602Â - XFOR: Exchange Migration Wizard Stops Responding After You Use Outlook 2000
http://support.microsoft.com/default.aspx?scid=kb;EN-US;243659
Additional Information
Formerly known as NETIQKB36709