Error: 'There is no such object on the server' when an Assistant Admin attempts to view the properti (NETIQKB36576)

  • 7736576
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.60

fact
Directory and Resource Administrator 7.x

symptom
Error: 'There is no such object on the server' when an Assistant Admin attempts to view the properties of a user account.

symptom
Error: 'The object does not exist' when an Assistant Admin attempts to view the properties of a user account.

symptom

Assistant Admins receive the following error message when they attempt to view the properties of a user account that was just created:

There is no such object on the server

The properties of the account cannot be viewed by any Assistant Admin including DRA Admins (Built-in Admins) even after an Incremental Accounts Cache Refresh or a Full Accounts Cache Refresh has been performed.  The user account is displayed in the DRA console and the user name is displayed correctly, however attempts to view the properties of the account results in the above stated error message.



cause
There is a trailing space in the user account Name field.  Directory and Resource Administrator and Active Directory Users & Computer remove trailing spaces when a user account is created, but user accounts created using the ADSI provider and some migration tools do not strip trailing spaces when creating an account in Active Directory.  Automation triggers that modify the data or format of the Name (CN) or the Display Name of a user account may also add the trailing space.

fix

To remove trailing spaces, perform the following steps:

  1. Launch Active Directory Users & Computers and connect to the domain controller that DRA binds to.
  2. Select and right-click the user account in question and choose Rename.
  3. Remove the trailing space from the CN name.
  4. Press Enter and click OK in the Rename User window.
  5. Launch the Delegation and ConfigurationManagement console.
  6. Expand the Configuration Management node and select Managed Domains.
  7. Select the domain in question in the right pane, right-click and select Refresh Account Cache > Full Refresh.
  8. Click Yes on the warning message to begin a Full Accounts Cache Refresh and then click OK in the informational message.

Assistant Admins can now view the properties of the user account in the DRA console.  To prevent the trailling space with other user accounts, modify any automation triggers so they do not add trailing spaces to the CN and Display Name fields.



Additional Information

Formerly known as NETIQKB36576