Environment
NetIQ AppManager 7.0.x
Situation
The NetIQCTRL utility's listms command shows the MS status = error.
The following error messages appear in the agent's MCTRACE.LOG file:
commcenter-cSend: failed to write
putMapNextRec: out of space for field 3 size 116
Resolution
To resolve this issue:
- Stop the NetIQ AppManager Client Communications Manager (NetIQccm) and NetIQ AppManager Client Resource Monitor (NetIQmc) services on the target Server.
- Delete the mapque directory (%\NetIQ\AppManager\dat\mapque).
- Cold start theNetIQ AppManager Client Communications Manager (NetIQccm) service (-o in the Start parameter).
- Warm start theNetIQ AppManager Client Resource Monitor (NetIQmc) service (no value specified in the Start parameter).
Cause
The above situation occurs if the Mapque cache file is corrupt, or there are duplicate Mapque cache files in the ...\AppManager\dat\Mapque directory on the Agent system that the jobs or reports are being run against.
When the Mapque cache file is corrupt, or when there are more than one cache file in the Mapque directory, the NetIQmc and NetIQccm services can not properly communicate with each other on an Agent system.
This can result in jobs and reports not being properly shown as "Stopped" in the Operator Console, even after they have been properly completed on the Agent that they are running against.