Error occurs when attempting to view the Exchange 5.5 mailbox properties of a user account. (NETIQKB35900)

  • 7735900
  • 02-Feb-2007
  • 22-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.x

fact
Directory and Resource Administrator 7.x

fact
Microsoft Exchange Server 5.5

symptom
Error occurs when attempting to view the Exchange 5.5 mailbox properties of a user account.

symptom
Error: 'Unable to determine if an Exchange 5.5 mailbox exists for the user.'

symptom

Assistant Admins receive the following error message when attempting to view an Exchange 5.5 mailbox property of a user account:

Unable to determine if an Exchange 5.5 mailbox exists for the user:
'OnePoint://CN=user_name,DC=domain_name,module=exchange,Mailbox'. Verify that the exchange services are running.



symptom
Assistant Admins are initially able to modify the Exchange 5.5 Mailbox properties of a user account, but after closing the mailbox property page, attempting to go back and view properties of the same mailbox results in the above error.

cause
These errors occur if the LDAP port on the preferred Exchange 5.5 server is different than the LDAP port on the Exchange server on which the mailbox resides. Ensure that the LDAP port on the preferred Exchange server is the same as the LDAP port on the Exchange server on which the mailbox resides.  The following is how the Administration server attempts to manage Exchange 5.5 mailbox and an explanation on why it succeeds the first time and fails as soon as the update has successfully been performed:

  1. Directory and Resource Administrator (DRA) uses LDAP for searching, but uses DAPI to perform any read/write operations to the mailbox properties. In this case, the modify operation uses DAPI, and this succeeds, since it does not use LDAP.
  2. In general, DRA performs read operations against the preferred server.  DRA is able to find the mailbox initially (because DRA is able to make LDAP calls against the preferred server).
  3. After DRA modifies a mailbox, DRA caches the server name where the changes were written (in this case, the home server for that mailbox).  DRA then uses that server for any subsequent read or write operations for that mailbox.  This is necessary to avoid replication issues (if DRA continues to use the preferred server to view that mailbox, we would see the old values until Exchange replicated the new values back to the preferred server). 


fix
To resolve this issue ensure that the LDAP ports used by all the Exchange 5.5 servers in the Exchange Organization are configured to use the same port.  Also as a workaround to resolve this issue, you can perform an Accounts Cache Refresh for the domain in which the user exists.  The cached values are discarded during the Accounts Cache Refresh but the problem will re-occur again.

Additional Information

Formerly known as NETIQKB35900