Error received upgrading VSM database to 4.1: Cannot open database requested in login VigilEnt . L (NETIQKB35029)

  • 7735029
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
VigilEnt Security Manager 4.x

fact
Microsoft SQL Server 2000

symptom
Database errors are returned when trying to upgrade the database to 4.1.

symptom
Error: 'The version of the database you are trying to upgrade is:  'Cannot open database requested in login 'VigilEnt'.'  Login failed.  The installation program will now exit'.

symptom
Error: 'An error occurred obtaining the version of the current VigilEnt database'.


symptom
Error: 'This version of the current database is not supported in this database upgrade'.

cause
The cause of this issue is due to insufficient permissions on the Microsoft SQL server for the logged in account performing the upgrade.

fix

This issue can be resolved by temporarily allowing the logged in account adminstrative access to the Microsoft SQL server.  Follow the steps below to allow administrative access for the account performing the install:

  1. Launch SQL Sever Enterprise Manager as a SQL administrator.
  2. Under the SQL Server Group node expand the SQL server node.
  3. Expand the Security folder.
  4. Right-click the Logins folder and select New Login...
  5. Click ...  and browse to the specified user.
  6. Click Add.
  7. Click OK.


Additional Information

Formerly known as NETIQKB35029