An error is received when performing any operation using the Client Interface. (NETIQKB34908)

  • 7734908
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.x

fact
Directory and Resource Administrator 7.x

symptom
An error is received when performing any operation using the Client Interface.

symptom

Assistant Admins receive an error message when attempting to create, clone, modify objects or group memberships in a domain using the client interface.



symptom
Error: 'hr = 8007001f, 'A device attached to the system is not functioning'.

cause
The above error message is a generic error message, which is returned by Active Directory when a constraint violation has occurred.  For example, a constraint violation may occur if Directory and Resource Administrator (DRA) is unable to communicate with a domain controller due to network problems or if the domain controller DRA is communicating with is busy or simply does not repond.  In such a situation Assistant Admins performing operations using DRA over objects in the domain in question will receive this error message.

fix

In order to resolve this issue, please perform a Domain Cache refresh followed by a Full Accounts Cache refresh by performing the following steps:

  1. Launch Directory and Resource Administrator MMC (DRA 6.x)/Delegation and Configuration Console (DRA 7.x), while logged in as an Assistant Admin with Built-in Admin role
  2. Expand the Configuration node and select Administration server options
  3. Select Domain Cache
  4. Click Refresh Now
  5. Click OK and OK again
  6. Select the Managed and trusted domains node
  7. Select the domain in question and then click Properties
  8. Select the Schedule tab
  9. Click Full refresh now
  10. Click OK and OK again

The Domain Cache and the Full Accounts Cache refresh may take several minutes to complete.  Please review the Application Event log on the Directory and Resource Administrator server for any error messages or to verify that the refresh has completed successfully.  The Domain Cache and Full Accounts Cache refresh will attempt to connect to another domain controller in the domain which is online and responsive.



note
A constraint violation error may also occur if the domain controller in question is experiencing LSASS memory leak issues. In such situation, please contact Microsoft in order to determine the cause of the LSASS memory leak.

Additional Information

Formerly known as NETIQKB34908