The heartbeat check indicates that all servers are unavailable, however reports against those server (NETIQKB34561)

  • 7734561
  • 02-Feb-2007
  • 04-Jan-2008

Resolution

fact
VigilEnt Security Manager 3.x

fact
VigilEnt Security Manager 4.0

symptom
The heartbeat check indicates that all servers are unavailable, however reports against those servers run successfully.

cause

Results of a "heartbeat check" are dependent on several factors:  the status of the agent, the status of the target machine or endpoint, and the database update status.  The last known status of an object is stored in the database along with the time that status was set.  Balancing the need to know each network object status with the danger of creating a denial of service situation ,by constantly checking each object results in an automatic heartbeat check scheduled for every 30 minutes, by default (this increment can be configured in the VigilEnt Security Manager Configuration Utility).  During the automatic heartbeat, agents and servers that have recently been updated or have recently run a report are by-passed and their status is left unchanged.  The GUI refresh only refreshes what is currently in view.  Items in other tree structures which have been cached will not be updated and may not display the latest status when expanded.  A manual heartbeat check should force a status check. 



fix

VigilEnt Security Manager 4.1 includes several improvements to this functionality.   VSM 4.1 is available from the NetiQ support site:  https://www.netiq.com/support/default.asp.



note
The status of a target server whose agent is down will not be updated accurately. 

Additional Information

Formerly known as NETIQKB34561