A provider error occurs when running the Update Database Patch Level Query Knowledge Base report. (NETIQKB34478)

  • 7734478
  • 02-Feb-2007
  • 16-Aug-2007

Resolution

fact
VigilEnt Security Agent for Windows 4.0

fact
Update Database Patch Level Query Knowledge Base

symptom
A provider error occurs when running the Update Database Patch Level Query Knowledge Base report.

symptom
Error: 'Error generating report: Provider cannot be found.  It may not be properly installed'.

cause
Microsoft Jet 4.0 Service Pack 3 is not installed and is required if using Microsoft Data Access Components (MDAC) 2.6.

fix

Install Microsoft Jet 4.0 Service Pack 3 on the machine where the VigilEnt Security Agent for Windows is installed.

To install Jet 4.0 Service Pack 3 refer to the steps below:

  1. Locate the CD or Download of VigilEnt Security Manager 4.1.
  2. Using Windows Explorer locate the VSA for Windows folder in the main directory of the download or CD.
  3. Inside this folder locate the Third Party Folder and double click it.
  4. Locate the JET folder and double click it.
  5. Double-click Jet40Sp3_Comp.exe to install Jet on the machine hosting the VigilEnt Security Agent for Windows.


Additional Information

Formerly known as NETIQKB34478