Resolution
VigilEnt Security Manager 4.x
fact
VigilEnt Security Operations Center
symptom
When running a task against endpoints, the tabs show up as Tab1, Tab2, ...Tab12.
cause
The cause of this issue is due to a permissions issue with the Windows account being used to log on to the workstation running VigilEnt Security Operations Center. When running Vigilent Security Operations Center (VSOC) on a remote computer, the user must have the following permissions:
Read and Write access to the following Registry keys:
- HKEY_CURRENT_USER/Software/Pentasafe
- HKEY_LOCAL_MACHINE/Software/Pentasafe
fix
Refer to the steps below to give the Windows account access to the registry keys:
- Click Start and select Run.
- Type Regedt32 and click OK.
- Browse to the Registry key HKEY_CURRENT_USER/Software/Pentasafe.
- From the menu, click Security | Permissions.
- Click Add and add the specified user.
- With the new user selected, select the checkbox next to Full Control and click OK.
- Repeat steps 3 thru 6 for the Registry key HKEY_LOCAL_MACHINE/Software/Pentasafe.
Read and Write folder and file permissions to the Pentasafe folder.
By default, this folder is located under \Program Files\Pentasafe . For version 4.1 this folder is \Program Files\NetIQ VigilEnt Security Manager.
Refer to the steps below to give the Windows account access to the Pentasafe folder:
- Click Start and select Run.
- Type Explorer and click OK.
- In the left tree view, browse to the Pentasafe folder where VSOC is installed.
- Right-click the Pentasafe folder and select Properties.
- Click the Security tab.
- Click Add and add the specified user.
- With the new user selected, select the checkboxes next to Modify. This should automatically check the Write as well as Read boxes.
- Click OK.