All AppManager reports complete with data but no graphs or charts. (NETIQKB34032)

  • 7734032
  • 02-Feb-2007
  • 20-Aug-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

All AppManager reports complete with data but no graphs or charts.
ReportAM or category specific knowledge scripts take a very long time to complete. This can be hours or even days.
Creating a report with a small amount of data or a large amount of data does not make a difference.
When the report finally completes, data and tables in the report appear but there are no graphs or sometimes no graphics.

Checking the default.log in your report output directories, located by default in the %\Program Files\NetIQ\AppManager\web\Report directory, shows the following.
Numerous entries are found below:

2003/9/2, 16:7:53 - NetIQ Graphics Server started successfully.
2003/9/2, 16:7:56 - Starting NetIQ Graphics Server
2003/9/2, 16:7:56 - NetIQ Graphics Server started successfully.
2003/9/2, 16:7:59 - Starting NetIQ Graphics Server
2003/9/2, 16:7:59 - NetIQ Graphics Server started successfully.
2003/9/2, 16:8:2 - Starting NetIQ Graphics Server

Resolution

Download and install the latest version of DirectX from the following URL

http://www.microsoft.com/windows/Directx/default.aspx

NetIQ technical support also suggests that the latest video card drivers are applied on the report agent machine.



Cause

The server that is designated as the AppManager Report Agent does not have the latest DirectX drivers from Microsoft.  The NetIQ Graphics Server uses OpenGL to create graphs in reports.

Additional Information

Formerly known as NETIQKB34032