The server process could not be started because the configured identity is incorrect. Check the user (NETIQKB33595)

  • 7733595
  • 02-Feb-2007
  • 07-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

When running the ExchangeRT_CheckAddressBookEntry knowledge script, the following errors are received:

From the Application log:
DCOM got error "Overlapped I/O operation is in progress." and was unable to logon domain\user in order to run the server:

From the AppManager Event pane:
An error occurred while running the transaction
The server process could not be started because the configured identity is incorrect. Check the username and password.

From the AMRT log:
Ntiqcomcnfg.LocalUsers : Unable to validate Domain User. Problems contacting the domain controller while validating domain name and user account.

Resolution

This error may occur if the credentials specified in the Knoweledge Script contains the fully qualified domain name (DNS name) instead of the NetBIOS name of the domain.  The credentials should be specified in the following format

NetBIOS_Domain_Name\Username

This May also occur due to the dcom identity of the Mapism executeable.

  1. Go on the agent and go to START>RUN and type DCOMCNFG <ENTER>
  2. Go to Component Services > My Computer > DCOM Config > Mapism, Highlight it and select Properties
  3. Go to the IDENTITY tab
  4. This may "show" the correct user, but re-key in the correct user and password.
  5. After changing this, restart the NetIQ AppManager Client Resource Monitor Service on the agent and then restart or deploy a new ExchangeRT job

Cause

The error is due to the IDENTITY not being properly configured in DCOM for the MAPISM application, which is part of the ExchangeRT module for AppManager.

Additional Information

Formerly known as NETIQKB33595