Resolution
VigilEnt Security Manager 3.x
symptom
Error: 'Unable to connect to database' when logging in to VigilEnt Security Manager from a remote GUI.
cause
It is possible that the the domain user that is logged in on the GUI machine is not a member of the local Administrators group on the machine hosting core services or the domain user that is logged in on the GUI machine is not a member of an allowed group in the "Access this computer from the network" setting.
fix
Either add the domain user that is logged in on the GUI machine to the local Administrators group on the machine hosting core services.
- Open Control Panel | Users and Groups
- Select the localAdministrators group.
- Select Add User and add the domain user logged in at the GUI machine to the Administrators Group.
OR
Check the Local Security Policy | User Rights Assignment on the machine hosting core services and make sure that the user is a member of an allowed group in the "Access this computer from the network" setting.
- Click on Start | Settings | Control Panel | Administrative Tools | Local Security Policy.
- Select Local Policies | User Rights Assignment.
- Double-click Access this computer from the network and add the domain user to an allowed group.