Error: 'OpenConnection: Error 3706. ADO could not find the specified provider. Unable to connect to (NETIQKB32054)

  • 7732054
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Manager 4.x

fact
VigilEnt Security Manager 3.x

symptom
Error: 'OpenConnection: Error 3706. ADO could not find the specified provider. Unable to connect to DB' received when logging into VigilEnt Security Manager.

cause
This error occurs when Microsoft Data Access Components (MDAC) are not present on the machine.

fix

Install Microsoft Data Access Components (MDAC) from the VigilEnt Security Manager (VSM) CD by following the steps below:

  1. Before installing MDAC stop both the VigilEnt Security Server service and the MSSQL Server service.  For assistance stopping services on a Windows machine please refer to:
    • NETIQKB25651: How do I start, stop, pause, resume, or restart a Microsoft Windows service?.
  2. locate the file MDAC_TYP.EXE within the following folder:
    • For VSM 3.x: Third Party | MDAC.  
    • For VSM 4.x: Prereq | MDAC.
  3. Double-click the executable and follow the prompts to complete the install.

NOTE:  Microsoft Windows 2000 requires MDAC minimum version 2.6 which can be downloaded from Microsoft's website at http://msdn.microsoft.com/library/default.asp?url=/downloads/list/dataaccess.asp.  The installation of MDAC may require a reboot of the machine.



Additional Information

Formerly known as NETIQKB32054