Error: 'Java.lang.Exception(Failed to open registry on \\<machine name>)'. (NETIQKB32038)

  • 7732038
  • 02-Feb-2007
  • 08-Nov-2007

Resolution

fact
NetIQ Vulnerability Manager 5.0

fact
NetIQ Vulnerability Manager 5.5

fact
NetIQ Vulnerability Manager Agent for Windows 5.5

fact
NetIQ Vulnerability Manager Agent for Windows 5.0

fact
VigilEnt Security Agent for Windows 3.x

fact
VigilEnt Security Manager 3.x

fact
VigilEnt Security Manager 2.x

symptom
Error: 'Java.lang.Exception(Failed to open registry on \\<machine name> )' occurs when running reports against the Windows agent.

symptom
Error message is displayed in report and log file.

cause
The VigilEnt Security Agent for Windows or NetIQ VigilEnt Agent (NetIQ Vulnerability Manager 5.0) service is started with an account that does not have domain administrator permissions for proxy reports or local administrator permissions for local reports.

fix

To address this issue, change the Logon As account for the respective service to a domain administrator or a local administrator account (as indicated above):

  1. Open Services from the Microsoft Windows Control Panel.
    • For Windows NT:  Go to Control Panel | Services.
    • For Windows 2000:  Go to Control Panel | Administrative Tools | Services.
  2. Right-click VigilEnt Security Agent For Windows or NetIQ VigilEnt Agent and select Properties.
  3. Select the Logon button or tab (depending on your operating system).
  4. Provide a domain administrator account in the  Logon As box along with the account password.
  5. Stop and Start the VigilEnt Security Agent for Windows or NetIQ VigilEnt Agent service.


Additional Information

Formerly known as NETIQKB32038