Error results when right-clicking a report in Completed Tasks and selecting Run Again. (NETIQKB31876)

  • 7731876
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
VigilEnt Security Manager 2.2

fact
VigilEnt Security Manager 2.3

fact
VigilEnt Security Manager 3.0

fact
VigilEnt User Manager / Password Management 1.0

symptom
Error results when right-clicking a report in Completed Tasks and selecting Run Again.

symptom
Error: "Unhandled exceptionoccurred:Java.SQL.SQLException:[machine name]Cannot insert the value NULL into columnTaskID' ,table'VigilEnt.dbo.RequestMembers'; column does not allow nulls.INSERT fails."

cause
The command for this report is no longer in the database. This has occurred because a special VigilEnt User Manager License to restrict anything but 'User/Group' reports has been applied to VigilEnt Security Manager.

fix

The only way to resolve this issue is to fully reinstall the VigilEnt Security Manager database. The license key added to VigilEnt Security Manager deletes the commands from the database and they cannot be added again by changing the license key.  Please contact Technical Support for assistance with this process.

https://www.netiq.com/support/vsa/phone.asp



Additional Information

Formerly known as NETIQKB31876