Access Denied error occurs when running Windows reports. (NETIQKB31547)

  • 7731547
  • 02-Feb-2007
  • 16-Aug-2007

Resolution

fact
VigilEnt Security Agent for Windows 3.x

fact
VigilEnt Security Agent for Windows 4.0

symptom
Access Denied error occurs when running Windows reports.

symptom
Error: 'Access Denied'.

cause
DCOM permissions are not set properly.

fix

To set the proper DCOM permissions, follow these steps on the machine hosting the VigilEnt Security Agent for Windows: 

  1. Click Start  |  Run and type CMD .
  2. At the command prompt, type dcomcnfg .
  3. Once the DCOM configuration box opens, select the Default Security tab.
  4. Select  Edit Default in Default Access permissions. 
  5. Click Add.
  6. Select the user account that is the Logon As: account for the VigilEnt Security Agent for Windows service. To find the user account that is currently specified as the Logon As: account for this service:

    1. Open the Services Control Manager.
    2. Right-click the VigilEnt Security Agent for Windows service and select Properties.
    3. Click the Log On tab.
    4. The user account specified in This account: is the account you should select in the Default Access permissions of the DCOM configuration.

  7. Click Apply and OK.


Additional Information

Formerly known as NETIQKB31547