The PSDetect alert monitor, PSDALTMON, stays in HOLD status when the QHST history log file is being (NETIQKB30922)

  • 7730922
  • 02-Feb-2007
  • 11-Mar-2014

Environment

VigilEnt Security Agent for iSeries
NetIQ Security Solutions for iSeries 8.0
NetIQ Security Solutions for iSeries 8.1
PSDETECT

Situation

The PSDetect alert monitor, PSDALTMON, stays in HOLD status when the QHST history log file is being cycled and is then available again.
QHST Alert Queue is put on hold.
PSDALTMON stops monitoring QHST.

Resolution

PTFs 1D00029 (for 2.1) and 1D01510 for (2.2) will resolve the issue where PSDALTMON is not released once QHST is available again for PSDetect to monitor. It builds in a longer wait time while checking for the history log file to be available after cycling to a new one.
 
Later versions (7.5/8.0/8.1) just need to have the alert queue released (unheld) to be able to start

Cause

If the Alert Monitor cannot allocate the QHST message log, then it will put the PSDetect QHST Alert Queue on hold.

Additional Information

Formerly known as NETIQKB30922